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Statistics and Statistical Inference 

•Statistics is the science that relates data to 
specific questions of interest. This includes devising 

– methods to gather data 
relevant to the question, 

– methods to summarize and display the data
to shed light on the question,

– methods that enable us to draw answers 
to the question that are supported by the data. 

• Different from other disciplines: 
data almost always contain uncertainty.

• Statistics is a science about uncertainty
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Statistical inference gives us methods and 
tools for data analysis. 
– there is a probability model explaining how the 

uncertainty gets into the data.
– data are generated in accordance with some 

unknown probability distribution
– By analyzing the data, we attempt 

to learn about the unknown distribution, 
To make some inferences about certain properties of the 
distribution, and 
to determine the relative likelihood that each possible 
distribution is actually the correct one.
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Some well-known statistics/math softwares
– SAS
– SPSS
– STATA
– Minitab
– Matlab ( a toolbox)
– S-Plus

All of them are NOT free

Statistical Softwares 
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Free statistics/math softwares
– Maxima  vs.  maple/mathematica
– Octave/scilab  vs.  Matlab
– R vs. S-plus

My points of view: 
Free does not always mean “not safe or useful”
– Maxima, Scilab and R are popular and reliable 

softwares!
– Linux are better than Windows
– (La)TeX are more popular and better than 

word/Power Point. 
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What is R and why R?
R first appeared in 1996, when the statistics professors Robert 
Gentleman, left, and Ross Ihaka released the code as a free software 
package (under GNU General Public License).

Ross IhakaRobert Gentleman

http://www.r-project.org/COPYING
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– R is a language and environment 
– R is an integrated suite of software facilities for data 

manipulation, calculation and graphical display. It 
includes

an effective data handling and storage facility, 
a suite of operators for calculations on arrays/ matrices, 
a large, coherent, integrated collection of intermediate tools 
for data analysis, 
graphical facilities for data analysis and display
a well-developed, simple and effective programming 
language which includes conditionals, loops, user-defined 
recursive functions and input and output facilities. 

From  http://www.r-project.org/about.html

http://www.r-project.org/about.html
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Why R? 
– Data Analysts Captivated by R’s Power (Ashlee 

Vance, The New York Times, Jan 6, 2009) give the 
answer:

R is an open-source program, and its popularity reflects a 
shift in the type of software used inside corporations.
… statisticians, engineers and scientists without computer 
programming skills find it easy to use
They can improve the software’s code or write variations for 
specific tasks. 
“The great beauty of R is that you can modify it to do all 
sorts of things,” said Hal Varian, chief economist at Google.

From http://www.nytimes.com/2009/01/07/technology/business-computing
/07program.html?_r=4

http://topics.nytimes.com/top/reference/timestopics/people/v/ashlee_vance/index.html?inline=nyt-per
http://topics.nytimes.com/top/reference/timestopics/people/v/ashlee_vance/index.html?inline=nyt-per
http://www.nytimes.com/2009/01/07/technology/business-computing
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Now R is surpassing what Mr. Chambers had imagined 
possible with S.
“R has really become the second language for people 
coming out of grad school now, and there’s an amazing 
amount of code being written for it,” said Max Kuhn, 
associate director of nonclinical statistics at Pfizer. 
while SAS plays down R’s corporate appeal, companies like 
Google and Pfizer say they use the software for just about 
anything they can
“R is a real demonstration of the power of collaboration, and 
I don’t think you could construct something like this any 
other way,” Mr. Ihaka said. “We could have chosen to be 
commercial, and we would have sold five copies of the 
software.”
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Bayesian Inference/Modeling

Main Approaches to Statistics
– Frequentist/classical approach, which is based on:

Parameters, the numerical characteristics of the population, 
are fixed but unknown constants.
Probabilities are always interpreted as long run relative 
frequency.
Statistical procedures are judged by how well they perform 
in the long run over an infinite number of hypothetical 
repetitions of the experiment.
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– Bayesain approach, the ideas of which are:
Parameters are considered  as random.
Probability statements about parameters must be 
interpreted as "degree of belief." The  prior distribution must 
be subjective.
We revise our beliefs about parameters after getting the 
data by using Bayes' theorem.
The posterior distribution comes from two sources: the prior 
distribution and the observed data.

– The Bayesian approach forms the basis of science --
learning process:  As we get more data, we add to 
our store of information by multiplying it by our 
current posterior distribution. 
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What is BUGS/WinBUGS?

Logo of BUGS
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– BUGS (Bayesian inference Using Gibbs 
Sampling)  is a popular software for 
analyzing complex statistical models using 
Markov Chain Monte Carlo (MCMC) methods

– It uses
Gibbs sampling
Metropolis algorithm
to generate a Markov chain by sampling 
from full conditional distributions.

What is BUGS?
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History(http://www.mrc-bsu.cam.ac.uk/bugs/)
– a command-line interface. Not further developed 

since 1996.
– Originate at the MRC BIOSTATISTICAL UNIT in 

Cambridge
– Later developed into WinBUGS, jointly with the 

Imperial College School of Medicine at St Mary’s, 
London.

– OpenBUGS, completely revised version of WinBugs, 
developed in the University of Helsinki, Finland.

– Add-on or interfaces: GeoBUGS, PKBUGS,……
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BUGS

Classic BUGS

WinBUGS (Windows Version)

GeoBUGS (spatial models)     

PKBUGS (pharmacokinetic modeling)

OpenBUGS (Windows Version)

DoodleBUGS (graphical modeling)
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What is WinBUGS?

WinBUGS, a windows program with an option of a 
graphical user interface, the standard ‘point-and-click’ 
windows interface, and on-line monitoring and 
convergence diagnostics. It also supports Batch-mode 
running (version 1.4).
GeoBUGS, an add-on to WinBUGS that fits spatial 
models and produces a range of maps as output. 
PKBUGS, an efficient and user-friendly interface for 
specifying complex population pharmacokinetic 
pharmacokinetic and pharmacodynamic (PK/PD) 
models within WinBUGS software.
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Why use WinBUGS?

• Its ability to fit complex statistical models
using MCMC methods. 

• Its flexibility to program, two different ways 
to specify model
− DoodleBUGS: Direct graphics
− BUGS language

• Free to download：
http://www.mrc-bsu.cam.ac.uk/bugs.

• A lot of examples in WinBUGS
• A lot of online resources

http://www.mrc-bsu.cam.ac.uk/bugs/
weblinks/webresource.shtml
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Package needs to be downloaded 
– WinBUGS14.exe

Potential useful packages
– CODA (Convergence Diagnostic and Output 

Analysis) 
– BOA (Bayesian Output Analysis)
– JAGS(Just Anothert Gibbs Sampler)---for analysis 

of Bayesain hierarchical models.
– R2WinBUGS---A package for Running WinBUGS 

from R

Related packges
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Working with BUGS

Output 
Analysis

R/Splus
STATA

Prepare 
Data

Editor
Spread sheet

BUGS 
Analysis

WinBUGS
BUGS
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How to use WinBUGS

Step 1: Specify the model to run
Step 2: Load the data and initial values for a 
specified number of chains
Step 3: Run WinBugs to get the Markov chains 
and save the results for the parameters for later 
use.
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unemployed  proportion p in the population? 
– p is in [0, 1], where 0 means no one is unemployed 

and 1 means everyone is.
– prior information of p (from newspaper reports, 

economic theory, previous surveys, etc.) can be used. 
– choose a beta prior distribution restricted between 0.1 

and 0.6.
– Data: n = 14 people were surveyed and r = 4 of them 

were unemployed.

A start example via DoodleBUGS
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Method 1: directly write a WinBUGS document( in 
BUGS language)
Method 2: Draw a directed graph in DoodleBUGS
and then transfer into a WinBUGS document. 
– Start WinBUGS
– Select “Doodle” from menu bar
– Select “New…” 
– Press “ok”
– You have a window to “Doodle” in.
– Creating a node 

Mouse click in Doodle Window

Model Specification in WinBUGS 



华
东
师
范
大
学

金
融
与
统
计
学
院

- 27 -

A node has a name and type along with other 
characteristics and parameters depending on 
its type.
Delete a node: 

highlight it
CTRL + Del
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Node Types
– Stochastic 
– Logical
– Constant (rectangle)

Create node p, click on and type/choose
– Name:  p
– Type: stochastic
– Density: dbeta
– A:1; b:1 (beta parameters) 
– lower bound:0.1; upper bound: 0.6
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• Two ways to transfer into a WinBUGS document
1. Menu bar > Doodle > Write Code.

• highlight the code > Click on Attributes > 16 point.
• ~ is read “distributed as”

WinBUGS document



华
东
师
范
大
学

金
融
与
统
计
学
院

- 30 -

2.   Select/ Copy/Paste your doodle 
into WinBUGS new document (still a doodle!)
• Menu bar > File > New
• Menu bar > Edit > Copy
• Menu bar > Edit > Paste 

Simplest doodle—a directed graph
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Running BUGS

• Menu bar > model > Specification… 
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Checks
Syntax

Start
Sampler

Check 
Model

Load
Data

Compile
Model

Initial
Values

Update
Sampler
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use WinBUGS to look at samples from our prior
Check Model
– Select the Doodle (note the hairy boarder)
– Menu bar - Model - Check model
– Note the message in bottom left hand corner

Compiling the Model
– Menu bar - Model - Compile
– Bottom left hand corner
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Load Initial Values
– Menu bar - Model - Gen inits
– Bottom left hand side

Before produce result, select Options > Output 
options > Select the log radio button.
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Update the Model
– Menu bar - Model – Update
– 1000 MCMC updates to be

carried out.
– Note: 

Model has been updated
MCMC run did not store any 
data---useful for “burn-in”
Store values by “monitoring” 
them to 

– Draw inferences 
– Monitor MCMC run
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Monitoring Nodes
– Monitoring p, our parameter of interest
– Menu bar - Inference - Samples...
– Type name of node “p” to monitor
– Press “set”

Sample Monitor Tool



华
东
师
范
大
学

金
融
与
统
计
学
院

- 37 -

Update & Monitor
– Update model again
– 1000 values “monitored” of the MCMC run for p
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WinBUGS output--1

Summary Statistics
– Select “p” from the Sample Monitor Tool
– Press “stats”  (Sample Monitor Tool)

MCMC Time Series
– Press “History” in Sample Monitor Tool

Kernel Density
– Press “Density” in the Sample Monitor Tool



华
东
师
范
大
学

金
融
与
统
计
学
院

- 39 -
Output results in log file



华
东
师
范
大
学

金
融
与
统
计
学
院

- 40 -

Inference:combining prior with data

For unemployment example, n = 14 people 
were surveyed and r = 4 of them were 
unemployed.
Bayesian Model: Beta – Binomial

N=14 (order), a=1, b=1. Change p to be 
restricted between 0.2 and 0.45.

  
|

~ ( , )
~ ( , )r p

p Beta a b
Bin N p

⎧
⎨
⎩
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New doodle/directed graph
– Create a stochastic node p in (0.2, 0.45) (done!) 
– Add a node N

name: N
type: constant

– Add a node r 
Name: r
type: stochastic
density:  dbin(binomial), with proportion p and order N.

– add links between the nodes :
click on node r (highlighted) .,
With the Ctrl key held, click on node p and node N.
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Two relationships in a noodle
– Single arrows: stochastic dependencies/

statistical relationship (is distributed as)
– hollow arrows: logical relationship

Beta-binomial doodle/directed graph
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To see the code
– Select Doodle > Write Code

To enter the data, in the model code window
list(N=14,r=4)
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Select Model > Specification..., do

– WinBUGS calculate the appropriate likelihood function 
and prior for p, and combine them into a posterior 
distribution. (straightforward for conjugate) 

Select Model > Update...,change updates to 
5000
– WinBUGS generates updated samples of p(from the 

initial) by combining the prior information on p and the 
new information on p given by the data r and N.

Running BUGS again!
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WinBUGS output--2

N=14,r=4

N=140,r=40
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2nd example: two props comparison

Two surveys are taken:
– N1=14, r1=4
– N2=12, r2=5

Question: What is the evidence that the 
underlying rates for the two surveys is really 
different?
Naïve thinking: 4/14=29%,5/12=42% -> the 
difference appears to be large.
Bayesian analysis using WinBUGS: calculate a 
posterior for the difference or ratio



华
东
师
范
大
学

金
融
与
统
计
学
院

- 47 -

Create two sets of nodes as in 1st example
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create two logical nodes

1. 
type:   logical
name: ratio
link:     identity
value:  p2/p1

2.  
type:   logical
name: difference
link:     identity
value:  p2-p1.
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Add the links to finish the model.

Directed Graph
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corresponding code for the two proportion 
model: Select Doodle > Write Code
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Summary: node connectors:

Add the data before analyzing the model 
– In the model window type: 

list(N1=14, r1=4, N2=12, r2=5)

connector Solid arrow Hollow  arrow

meaning Stochastic /statistical 
relationship

Logical/deterministic
relationship

Sign in BUGS 
language <- ~
example diff<-p2-p1 r~dbin(p,N)
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Select Model > Specification..., do

Sample Monitor Tool to set ratio and difference
Select Model > Update...,change updates to 
5000

Running BUGS again!
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WinBUGS output--3
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Conlusion

The sample rates of unemployment are NOT
significantly different. Reasons:
– The area under the difference curve to the right of 

zero is not much larger than the area to the left of 
zero. Also the area to the right of one under the ratio 
curve is not much larger than the area to the left of 
one.

– the mean difference is close to zero and the mean 
ratio is close to one

– 95% credible interval for difference (-0.16,0.20)
95% credible interval for ratio (0.61, 1.92)
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More complex models with plates

Plates
– Allow more complex 

structure, e.g.,
Repeated measures
Hierarchical models

Creating a plate 
– CTRL + mouse click

in Doodle Window
– Deleting a plate: 

CTRL + Del
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Case Study: pumps data

ti: the length of operation time of the pump (in 1000s of hours).
xi: the number of failures

PUMP ti xi

1 94.5 5
2 15.7 1
3 62.9 5
4 126 14
5 5.24 3
6 31.4 19
7 1.05 1
8 1.05 1
9 2.1 4

10 10.5 22
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Gamma-Poisson hierarchical model

Paramters of interest: 

 1, 2 ,  ...,  10
~ ( )
~ ( ,  )

            ~ (1 .0 )
            ~ (0 .1,  1 .0 )

i i i

i

fo r i
x P o isson t

G am m a
E xponen tia l
G am m a

θ
θ α β

α
β

=

, 1, 2, ,10i iθ = …
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Model specification through DoodleBUGS

• Nodes
– Constants, denoted by rectangles
– Stochastic nodes, denoted by ellipses
– Deterministic nodes, logical function of other nodes

• Edges
– Directed links

• Solid arrow: stochastic dependence
• Hollow arrow: logical function

– Undirected links, dashed line
• representing an upper or lower bound

• Plates, repeated parts of the graph



华
东
师
范
大
学

金
融
与
统
计
学
院

- 60 -

Constant node

Stochastic node

Plate

Stochastic 
relationship

logical 
relationship

Deterministic node
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Model specification through BUGS language

model
{

for (i in 1 : N) {
theta[i]~ dgamma(alpha,beta)
lambda[i] <- theta[i] * t[i]
x[i] ~ dpois(lambda[i])

}
alpha ~ dexp(1)
beta ~ dgamma(0.1, 1.0)

}
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Format data and specify initial values

Data format
– R/S-Plus format using list()

list(t = c(94.3, 15.7, 62.9, 126, 5.24, 31.4, 1.05, 1.05, 2.1, 10.5), 
x = c(5, 1, 5, 14, 3,  19, 1, 1, 4, 22), 
N = 10)

– Rectangular format

Initial values
list(alpha = 1, beta = 1)
list(alpha = 10, beta = 10)
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Data in rectangular format
– Data are usually stored in the 

same odc file with END sign
– To conserve space, hide/fold data 

in rectangular format  by
T o o l s > Create F o l d
Edit menu> select >copy>paste
between two arrows
A name can be inserted in between

– Load the data by highlight the first 
row

– Repeat the procedure for multiple 
sets of data
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What kind of output can WinBUGS give us?

What kind of sampling method  does WinBUGS 
implement?

Anything missing?
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Output of WinBUGS

Samples at Inference Menu
trace: plots the variable value against iteration number. 
history: plots out a complete trace for the variable.
density: smoothed kernel density estimate for 
continuous variable or a histogram for discrete variable.
auto cor: auto correlation, up to lag-50
stats: Summary statistics, pooling over the chains 
selected. 
coda: output the monitored values to CODA or BOA
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quantiles: plots out the running mean with running 
95% confidence intervals against iteration number.
bgr diag: Brooks-Gelman-Rubin convergence 
statistic Brooks and Gelman (1998)

Green: the width of the central 80% interval of the 
pooled runs 
Blue: the average width of the 80% intervals within the 
individual runs
Red: their ratio R (= pooled / within). 
Convergence: R to 1, and with convergence of both the 
pooled and within interval widths to stability.
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[1]
[2]

[3] [4]

[5]

[6]

[7]
[8]

[9]

[10]

box plot: theta

    0.0

    1.0

    2.0

    3.0

    4.0

• Compare at Inference Menu

[1]

[2]

[3]

[4]

[5]

[6]

[7]

[8]

[9]

[10]

caterpillar plot: theta

    0.0     1.0     2.0     3.0     4.0

Box Plot Caterpillar Plot
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• Rank at Inference Menu
• stats: the distribution of the ranks of each component of 

the variable. 
• histogram: the empirical distribution of the simulated 

rank for each component
• DIC at Inference Menu

• Deviance Information Criterion
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sampling methods in WinBUGS

Sampling methods are used in the following hierarchies 
--------------------------------------------------------------------------
• Continuous target distribution

- Conjugate Direct sampling using standard algorithms
- Log-concave Derivative-free adaptive rejection sampling 
- Non-log-concave (restricted range) Slice sampling
- Non-log-concave (unrestricted range) Metropolis

-------------------------------------------------------------------------
• Discrete target distribution

- Finite upper bound Inversion
- Shifted Poisson Direct sampling using standard algorithm
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R2WinBUGS:WinBUGS run in R 

It is a R package that provides the 
tools/functions to call WinBUGS directly.
It automatically writes the data and scripts in a 
format readable by WinBUGS for processing in 
batch mode.
Then it is possible to read resulting data into R 
to give 
– summary statistics
– graphical summary
– convergence diagnostics
– ……
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How to install R2WinBUGS

Suppose that the internet connection is available.
– Start R

– First way: at R command prompt type   

install.packages(“R2WinBUGS”)

– Second way: install from R menu “packages”
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How to use R2WinBUGS

We recommend to use R2WinEdt as a script editor
and use school data as an example---to fit the 
hierarchical normal model.
– Step 1: Start R
– Step 2: Start WinBUGS
– Step 3: load R2WinBUGS from R by typing 

library(“R2WinBUGS”) # or Before using bugs()
load RWinEdt from R by typing

library(“RWinEdt”)
Remark 1: We use the school data in Section 5.5 of 

"Bayesian Data Analysis(Gelman, 2004)“ to illustrate
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– Step 4: Model specification --- establish the Bugs 
model file: schools.bug

model {
for (j in 1:J){
y[j] ~ dnorm (theta[j], tau.y[j])

theta[j] ~ dnorm (mu.theta, tau.theta)
tau.y[j] <- pow(sigma.y[j], -2)

}
mu.theta ~ dnorm (0.0, 1.0E-6) 
tau.theta <- pow(sigma.theta, -2)
sigma.theta ~ dunif (0, 1000)

}
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Remark 2: In Bugs, the normal distribution is 
parameterized by its precision (=1/variance)

Remark 3: For convenience, use for precisions and     for 
standard deviations.
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– Step 5: data specification (school.dat)

school estimate    sd
A      28.39  14.9
B       7.94   10.2
C     -2.75    16.3
D      6.82    11.0
E      -0.64     9.4
F       0.63    11.4
G     18.01   10.4
H     12.16   17.6
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– Step 6: Data read, starting values and parameters 
specification (R_school_full.R)

schools<-read.table("c:/bugs.R/schools.dat",head=T)
J <- nrow(schools)
y <- schools$estimate
sigma.y <- schools$sd
data <- list("J","y","sigma.y")
inits <- function()

list(theta=rnorm(J,0,100), 
mu.theta=rnorm(1,0,100), 
sigma.theta=runif(1,0,100))
parameters <- c("theta","mu.theta","sigma.theta")
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Remark 5: Bugs does not require all parameters to be 
initialized, but it is a good idea to do so.

Starting values can be constructed 
– randomly (as in the example above)
– with simple initial values
– from crude estimates

演示者
演示文稿备注
With 
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Step 7: Run Bugs (MCMC simulation) with given number 
of chains for given number of iterations.

Remark 6: 
– n.chains= specifies the number  of chains
– n.iter= specifies the number of iterations

Remark 7: While Bugs is running, it opens a new window 
and freezes R. 

schools.sim <- bugs(data, inits, parameters, 
model.file="c:/bugs.R/schools.bug", n.chains=3, n.iter=1000, 
bugs.directory = "E:/WinBUGS14/")
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– Step 8: Show the resuts
8.1 Numerical output/summaries of the simulations for the 
parameters

8.2 Graphical summaries of the inferences and convergence. 

Remark 8: 
– n.eff : rough measure of effective sample size
– Rhat : potential scale reduction factor
– pD: effective number of parameters
– DIC: estimate of expected predictive error 

print(schools.sim) 
schools.sim$summary

plot(schools.sim)
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Summary

BUGS is a power tool
– Bayesian Analysis
– Simulation Tool

Model specification in WinBUGS
– Graphical Models

DoodleBUGS: Direct graphics
Simple representation of model

– BUGS language

WinBUGS run in R (R2WinBUGS)
also: in S-plus, Stata, SAS,… 
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WinBUGS is Easy to use!

But

MCMC sampling can be dangerous in 
WinBUGS !

A  Reminder 
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